Compatible Browsers and Devices for Accessing IMS Direct Interpreter portal

Compatible Browsers and Devices for Accessing IMS Direct Interpreter portal 

IMS Direct Interpreter portal will be accessible from all Windows and Apple Mac desktop and laptop computers.

IMS Direct Interpreter portal will be supported on the following internet browsers:

  • Firefox version 4 or later
  • Google Chrome version 10 or later
  • Safari version 5 or later
  • Opera 11 or later
  • Internet Explorer 9 or later

The portal access is not recommended for use on Smart Phones, separate Mobile Applications will be made available during early next year(2017).

The Portal should work on Tablet devices such as Surface and iPad if they are supported by up to date web browsers, should have any issues please share your experience with sending us a screenshot to provide the details.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk